

FOLLOWUS
School of Computer and Information Technology, Beijing Jiaotong University, Beijing 100044, China
[ "A-qun ZHAO, E-mail: aqzhao@bjtu.edu.cn" ]
Received:14 April 2011,
Revised:2011-12-16,
Published:2012-01
Scan QR Code
A-qun ZHAO, Man-gui LIANG. A new forwarding address for next generation networks[J]. Frontiers of Information Technology & Electronic Engineering, 2012, 13(1): 1-10.
A-qun ZHAO, Man-gui LIANG. A new forwarding address for next generation networks[J]. Frontiers of Information Technology & Electronic Engineering, 2012, 13(1): 1-10. DOI: 10.1631/jzus.C1100096.
The forwarding address plays an important role in constructing a communication network. In this paper
a new forwarding address suitable for next generation networks named the vector address (VA) is proposed which is different from the forwarding address coding methods of current networks. The characteristics of the VA are analyzed. Complex network theory and a theoretical analysis method are introduced to study the average address length of the VA when used to construct a global network. Simulation experiments in a practical network topology model are carried out to validate the results. The results show that not only can the VA construct a simpler
more secure
and more scalable network
but it also can accommodate many more users than an Internet Protocol (IP) network with the same address length.
A.L. Barabsi , , , R. Albert . . Emergence of scaling in random networks . . Science , , 1999 . . 286 ( ( 5439 ): ): 509 - - 512 . . DOI: 10.1126/science.286.5439.509 http://doi.org/10.1126/science.286.5439.509 . .
CCITT X.25:1977 . . Recommendation X.25-Interface Between Data Terminal Equipment (DTE) and Data Circuit- Terminating Equipment (DCE) for Terminals Operating in the Packet Mode on Public Data Networks . . International Telegraph and Telephone Consultative Committee (CCITT) Orange Book, Geneva, Switzerland, Vol. VIII-2 , , p.70 - - 108 . . . .
D.R. Cheriton , , , M. Gritter . . TRIAD: a Scalable Deployable NAT-Based Internet Architecture . . Available from , , 2000 . . 2011 http://www-dsg.stanford.edu/papers/triad/triad.html http://www-dsg.stanford.edu/papers/triad/triad.html , , [Accessed on Aug. 2, 2011] . .
R. Cohen , , , S. Havlin . . Scale-free networks are ultrasmall . . Phys. Rev. Lett. , , 2003 . . 90 ( ( 5 ): ): 058701 DOI: 10.1103/PhysRevLett.90.058701 http://doi.org/10.1103/PhysRevLett.90.058701 . .
D. Dellamonica , , , Y. Kohayakawa , , , V. Rdl , , , A. Ruciński . . Universality of Random Graphs . . Proc. 19th Annual ACM-SIAM Symp. on Discrete Algorithms , , 2008 . . p.782 - - 788 . . . .
S.N. Dorogovtsev , , , J.F.F. Mendes , , , A.N. Samukhin . . Structure of growing networks with preferential linking . . Phys. Rev. Lett. , , 2000 . . 85 ( ( 21 ): ): 4633 - - 4636 . . DOI: 10.1103/PhysRevLett.85.4633 http://doi.org/10.1103/PhysRevLett.85.4633 . .
P. Erdǒs , , , A. Rnyi . . On the evolution of random graphs . . Publ. Math. Inst. Hung. Acad. Sci. , , 1960 . . 5 17 - - 61 . . . .
P. Francis . . A near-term architecture for deploying Pip . . IEEE Network , , 1993 . . 7 ( ( 3 ): ): 30 - - 37 . . DOI: 10.1109/65.224021 http://doi.org/10.1109/65.224021 . .
P. Francis , , , R. Govindan . . Flexible Routing and Addressing for a Next Generation IP . . Proc. Conf. on Communications Architectures, Protocols and Applications , , 1994 . . p.116 - - 125 . . DOI: 10.1145/190314.190325 http://doi.org/10.1145/190314.190325 . .
D.R. He , , , Z.H. Liu , , , B.H. Wang . . Complex Systems and Complex Networks , , : : Beijing, China Higher Education Press , , 2009 . . .
D. Katz , , , P.S. Ford . . TUBA: replacing IP with CLNP . . IEEE Network , , 1993 . . 7 ( ( 3 ): ): 38 - - 47 . . DOI: 10.1109/65.224020 http://doi.org/10.1109/65.224020 . .
H.T. Kaur , , , S. Kalyanaraman , , , A. Weiss , , , S. Kanwar , , , A. Gandhi . . BANANAS: an Evolutionary Framework for Explicit and Multipath Routing in the Internet . . Proc. ACM SIGCOMM Workshop on Future Directions in Network Architecture , , 2003 . . p.277 - - 288 . . DOI: 10.1145/944759.944766 http://doi.org/10.1145/944759.944766 . .
Y. Li , , , H.D. Cao , , , X.M. Shan , , , Y. Ren . . An estimation formula for the average path length of scale-free networks . . Chin. Phys. B , , 2008 . . 17 ( ( 7 ): ): 2327 - - 2332 . . DOI: 10.1088/1674-1056/17/7/001 http://doi.org/10.1088/1674-1056/17/7/001 . .
M.G. Liang . . A Method for Vector Network Address Coding . . China Patent ZL200610089302.6 , , 2009a . . .
M.G. Liang . . A Method to Build Vector Connection in Vector Network . . China Patent ZL200710064804.8 , , 2009b . . .
M.G. Liang , , , J.X. Zhang , , , S.J. Wang . . A New Network Based on Vector Address . . IET 2nd Int. Conf. on Wireless, Mobile and Multimedia Networks , , 2008 . . p.118 - - 122 . . DOI: 10.1049/cp:20080951 http://doi.org/10.1049/cp:20080951 . .
D.E. McDysan , , , D.L. Spohn . . ATM Theory and Applications . . McGraw-Hill, New York, USA , , 1998 . . p.1 - - 12 . . . .
A. Medina , , , A. Lakhina , , , I. Matta , , , J. Byers . . BRITE: an Approach to Universal Topology Generation . . Proc. 9th Int. Symp. on Modeling, Analysis and Simulation of Computer and Telecommunication Systems , , 2001 . . p.346 - - 353 . . DOI: 10.1109/MASCOT.2001.948886 http://doi.org/10.1109/MASCOT.2001.948886 . .
M.E.J. Newman , , , D.J. Watts . . Renormalization group analysis of the small-world network model . . Phys. Lett. A , , 1999 . . 263 ( ( 4-6 ): ): 341 - - 346 . . DOI: 10.1016/S0375-9601(99)00757-4 http://doi.org/10.1016/S0375-9601(99)00757-4 . .
M.E.J. Newman , , , C. Moore , , , D.J. Watts . . Mean field solution of the small-world network model . . Phys. Rev. Lett. , , 2000 . . 84 ( ( 14 ): ): 3201 - - 3204 . . DOI: 10.1103/PhysRevLett.84.3201 http://doi.org/10.1103/PhysRevLett.84.3201 . .
RFC 791:1981 . . Internet Protocol . . IETF, Fremont, California, USA , , . .
RFC 2460:1998 . . Internet Protocol, Version 6 (IPv6) Specification . . IETF, Fremont, California, USA , , . .
RFC 3031:2001 . . Multiprotocol Label Switching Architecture . . IETF, Fremont, California, USA , , . .
P. Smith . . Frame Relay: Principles and Applications . . Addison-Wesley Longman Publishing Co., Inc., Boston, MA, USA , , 1993 . . p.159 - - 176 . . . .
I. Stoica , , , H. Zhang . . LIRA: an Approach for Service Differentiation in the Internet . . Proc. 8th Int. Workshop on Network and Operating Systems Support for Digital Audio and Video , , 1998 . . p.115 - - 128 . . . .
X.F. Wang , , , X. Li , , , G.R. Chen . . Complex Network Theory and Its Application , , : : Beijing, China Tsinghua University Press , , 2006 . . .
Z.W. Wang , , , M.G. Liang . . Vector Address Routing Protocol for MANET . . 9th Int. Conf. on Signal Processing , , 2008 . . p.2637 - - 2641 . . . .
Z.W. Wang , , , M.G. Liang , , , J.X. Zhang . . Vector Switching Scheme (VSS) for Source Routing Protocol of MANET . . IET 2nd Int. Conf. on Wireless, Mobile and Multimedia Networks , , 2008 . . p.58 - - 61 . . DOI: 10.1049/cp:20080936 http://doi.org/10.1049/cp:20080936 . .
D.J. Watts , , , S.H. Strogatz . . Collective dynamics of 'small-world' networks . . Nature , , 1998 . . 393 ( ( 6684 ): ): 440 - - 442 . . DOI: 10.1038/30918 http://doi.org/10.1038/30918 . .
X.W. Yang . . NIRA: a New Internet Routing Architecture . . Proc. ACM SIGCOMM Workshop on Future Directions in Network Architecture , , 2003 . . p.301 - - 312 . . DOI: 10.1145/944759.944768 http://doi.org/10.1145/944759.944768 . .
J.X. Zhang , , , M.G. Liang . . A Hierarchical Networking Architecture Based on New Switching Address . . Proc. Int. Conf. on Advanced Infocomm Technology , , 2008 . . p.326 - - 329 . . DOI: 10.1145/1509315.1509324 http://doi.org/10.1145/1509315.1509324 . .
J.X. Zhang , , , M.G. Liang . . The Third Kind of Communication Network . . Proc. 2nd Int. Conf. on Future Computer and Communication , , 2010 . . p.764 - - 768 . . DOI: 10.1109/ICFCC.2010.5497616 http://doi.org/10.1109/ICFCC.2010.5497616 . .
Z.Y. Zou , , , B.H. Mao , , , H.M. Hao , , , J.Z. Gao , , , J.J. Yang . . Regular small-world network . . Chin. Phys. Lett. , , 2009 . . 26 ( ( 11 ): ): 110502 DOI: 10.1088/0256-307X/26/11/110502 http://doi.org/10.1088/0256-307X/26/11/110502 . .
Publicity Resources
Related Articles
Related Author
Related Institution
京公网安备11010802024621