
FOLLOWUS
CERNET Center, Tsinghua University, Beijing 100084, China
Guo-liang HAN, E-mail: guoliang.taurus@gmail.com
[ "Cong-xiao BAO, E-mail:congxiao@cernet.edu.cn" ]
[ "Xing LI, E-mail:xing@cernet.edu.cn" ]
收稿:2015-01-14,
修回:2015-07-15,
纸质出版:2015-08
Scan QR Code
IPv6过渡场景中的可扩展高效IPv4地址共享机制研究[J]. 信息与电子工程前沿(英文), 2015,16(8):634-645.
HAN Guo-liang, BAO Cong-xiao, LI Xing. A scalable and efficient IPv4 address sharing approach in IPv6 transition scenarios[J]. Frontiers of Information Technology & Electronic Engineering, 2015, 16(8): 634-645.
IPv6过渡场景中的可扩展高效IPv4地址共享机制研究[J]. 信息与电子工程前沿(英文), 2015,16(8):634-645. DOI: 10.1631/FITEE.1500022.
HAN Guo-liang, BAO Cong-xiao, LI Xing. A scalable and efficient IPv4 address sharing approach in IPv6 transition scenarios[J]. Frontiers of Information Technology & Electronic Engineering, 2015, 16(8): 634-645. DOI: 10.1631/FITEE.1500022.
目的
2
在IPv6过渡方案中,研究同时具有良好可扩展性、灵活性和IPv4地址共享效率的IPv4地址共享机制,以促进IPv6的过渡进程。
创新点
2
在已有IPv6过渡机制基础上,提出一种混合的数据通路动态切换机制,可以兼顾已有的无状态机制和有状态机制的优点,从而实现良好的可扩展性、灵活性、安全性和高效的IPv4地址共享。该机制尤其适用于IPv4地址匮乏但用户数量很多的网络,可以在保证用户体验的同时充分促进该网络向IPv6的过渡。在此机制基础上,提出根据实际情况进行灵活的地址规划的方法。
方法
2
首先,针对当前的IPv4地址共享机制的不足,提出并设计混合的数据通路动态切换机制,其中动态切换的过程由用户侧网关完成。然后,设计该机制的组成模块,并分别讨论其实现算法和细节。接下来,将整个系统实现并部署在连接至IPv6骨干网CERNET2的清华大学校园网中,通过实际流量数据分析该机制对有状态通路和无状态通路上流量和端口消耗的影响,验证该机制的可行性和有效性。最后,在此机制基础上,提出根据实际情况进行灵活的地址规划的方法。
结论
2
本文所提方法可以有效地使用有限的IPv4地址而不降低终端性能。实验结果(图6-8)验证了所提方法的有效性。该方法尤其适用于具有大量用户且希望使用有限IPv4地址的网络。
IPv6 has been an inevitable trend with the depletion of the global IPv4 address space. However
new IPv6 users still need public IPv4 addresses to access global IPv4 users/resources
making it important for providers to share scarce global IPv4 addresses effectively. There are two categories of solutions to the problem
carrier-grade NAT (CGN) and 'A+P' (each customer sharing the same IPv4 address is assigned an excluded port range). However
both of them have limitations. Specifically
CGN solutions are not scalable and can bring much complexity in managing customers in large-scale deployments
while A+P solutions are not flexible enough to meet dynamic port requirements. In this paper
we propose a hybrid mechanism to improve current solutions and have deployed it in the Tsinghua University Campus Network. The real traffic data shows that our mechanism can utilize limited IPv4 addresses efficiently without degrading the performance of applications on end hosts. Based on the enhanced mechanism
we propose a method to help service providers make address plans based on their own traffic patterns and actual requirements.
S. Alcock . Research into the Viability of ServiceProvider NAT . Available from , [Accessed on Jan. 8, 2015] 2008 . http://www.wand.net.nz/~salcock/someisp/flow_counting/result_page.html http://www.wand.net.nz/~salcock/someisp/flow_counting/result_page.html , .
S. Alcock , R. Nelson . Measuring and characterising inbound sessions in residential DSL traffic . Proc. Australasian Telecommunication Networks and Applications Conf. , 2011 . p.1 - 6 . DOI: 10.1109/ATNAC.2011.6096628 http://doi.org/10.1109/ATNAC.2011.6096628 .
S. Alcock , R. Nelson , D. Miles . Investigating the impact of service provider NAT on residential broadband users . Proc. IEEE INFOCOM , 2010 .
F. Audet , C. Jennings . Network Address Translation (NAT) Behavioral Requirements for Unicast UDP . RFC 4787 , 2007 . DOI: 10.17487/RFC4787 http://doi.org/10.17487/RFC4787 .
M. Bagnulo . Sharing of an IPv4 Address . Available from , [Accessed on Jan. 8, 2015] 2009 . http://www.ietf.org/proceedings/74/shara.html http://www.ietf.org/proceedings/74/shara.html , .
G. Bajko , M. Boucadair , R. Bush , 等 . Overview of Shared Address Solution Space . Available from , [Accessed on Jan. 8, 2015] 2009 . http://www.ietf.org/proceedings/74/slides/shara-9.pdf http://www.ietf.org/proceedings/74/slides/shara-9.pdf , .
M. Chen , X. Li , A. Li , 等 . Forwarding IPv4 traffics in pure IPv6 backbone with stateless address mapping . Proc. 10th IEEE/IFIP Network Operations and Management Symp. , 2006 . p.260 - 270 . DOI: 10.1109/NOMS.2006.1687557 http://doi.org/10.1109/NOMS.2006.1687557 .
Y. Cui , Q. Sun , M. Boucadair , 等 . Lightweight 4over6: an Extension to the DS-Lite Architecture . Available from , [Accessed on Jan. 8, 2015] 2014 . https://tools.ietf.org/html/draft-cuisoftwire-b4-translated-ds-lite-05 https://tools.ietf.org/html/draft-cuisoftwire-b4-translated-ds-lite-05 , .
R. Després . Port-Range Based IPv4 Address Space Extensionja Static Approach Based on SAM . Available from , [Accessed on Jan. 8, 2015] 2009a . http://www.ietf.org/proceedings/74/slides/shara-7.pdf http://www.ietf.org/proceedings/74/slides/shara-7.pdf , .
R. Després . Scalable Multihoming across IPv6 Local-Address Routing Zones Global-Prefix/LocalAddress Stateless Address Mapping (SAM) . Available from , [Accessed on Jan. 8, 2015] 2009b . https://tools.ietf.org/html/draft-despres-sam-03 https://tools.ietf.org/html/draft-despres-sam-03 , .
R. Després , S. Jiang , R. Penno , 等 . IPv4 Residual Deployment via IPv6—a Stateless Solution (4rd) , 2014 .
A. Durand . Dual-Stack Lite . Available from , [Accessed on Jan. 8, 2015] 2009 . http://lacnic.net/documentos/lacnicxii/presentaciones/flip6/02_Alain_Durand.pdf http://lacnic.net/documentos/lacnicxii/presentaciones/flip6/02_Alain_Durand.pdf , .
A. Durand , R. Droms , J. Woodyatt , 等 . DualStack Lite Broadband Deployments Following IPv4 Exhaustion . RFC 6333 , 2011 .
A. Fiocco . Two Months after World IPv6 Launch, Measuring IPv6 Adoption: 6lab.cisco.com/stats . Available from , [Accessed on Jan. 8, 2015] 2012 . http://blogs.cisco.com/news/two-monthsafter-world-ipv6-launch-measuring-ipv6-adoption-6labcisco-comstats http://blogs.cisco.com/news/two-monthsafter-world-ipv6-launch-measuring-ipv6-adoption-6labcisco-comstats , .
M. Ford , M. Boucadair , A. Durand , 等 . Issues with IP Address Sharing . RFC 6269 , 2011 . DOI: 10.17487/RFC6269 http://doi.org/10.17487/RFC6269 .
S. Guha , K. Biswas , B. Ford , 等 . NAT Behavioral Requirements for TCP . RFC 5382 , 2008 . DOI: 10.17487/RFC5382 http://doi.org/10.17487/RFC5382 .
D. Hankins , T. Mrugalski . Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Option for Dual-Stack Lite . RFC 6334 , 2011 . DOI: 10.17487/RFC6334 http://doi.org/10.17487/RFC6334 .
A. Herzberg , H. Shulman . Socket overloading for fun and cache-poisoning . Proc. 29th Annual Computer Security Applications Conf. , 2013 . p.189 - 198 . DOI: 10.1145/2523649.2523662 http://doi.org/10.1145/2523649.2523662 .
G. Huston . NAT++: address sharing in IPv4 . Int. Proto. J. , 2009 . 13 ( 2 ): 1 - 10 . .
G. Huston . IPv4 Address Report . Available from , [Accessed on Jan. 8, 2015] 2014 . http://www.potaroo.net/tools/ipv4/index.html http://www.potaroo.net/tools/ipv4/index.html , .
D. Kaminsky . Black Ops 2008: Itos the End of the Cache as We Know It . Black Hat USA , 2008 .
X. Li , C. Bao , M. Chen , 等 . The China Education and Research Network (CERNET) IVI Translation Design and Deployment for the IPv4/IPv6 Coexistence and Transition . RFC 6219 , 2011 . DOI: 10.17487/RFC6219 http://doi.org/10.17487/RFC6219 .
X. Li , C. Bao , W. Dec , 等 . Mapping of Address and Port Using Translation (MAP-T) . Available from , [Accessed on Jan. 8, 2015] 2014 . https://tools.ietf.org/html/draft-ietfsoftwire-map-t-08 https://tools.ietf.org/html/draft-ietfsoftwire-map-t-08 , .
T. Mrugalski , O. Troan , I. Farrer , 等 . DHCPv6 Options for Configuration of Softwire Address and Port Mapped Clients . Available from , [Accessed on Jan. 8, 2015] 2015 . https://tools.ietf.org/html/draft-ietf-softwiremap-dhcp-12 https://tools.ietf.org/html/draft-ietf-softwiremap-dhcp-12 , .
A. Ramaiah , P. Tate . Effects of Port Randomization with TCP TIME-WAIT State , 2008 .
A. Ripke , R. Winter , M. Brunner , 等 . The impact of port-based address-sharing on residential broadband access networks . Proc. IEEE Global Telecommunications Conf. , 2010 . p.1 - 6 . DOI: 10.1109/GLOCOM.2010.5683449 http://doi.org/10.1109/GLOCOM.2010.5683449 .
F. Schneider , S. Agarwal , T. Alpcan , 等 . The new web: characterizing AJAX traffic . Proc. 9th Int. Conf. on Passive and Active Network Measurement , 2008 . p.31 - 40 . DOI: 10.1007/978-3-540-79232-1_4 http://doi.org/10.1007/978-3-540-79232-1_4 .
F. Schneider , A. Feldmann , B. Krishnamurthy , 等 . Understanding online social network usage from a network perspective . Proc. 9th ACM SIGCOMM Conf. on Internet Measurement , 2009 . p.35 - 48 . DOI: 10.1145/1644893.1644899 http://doi.org/10.1145/1644893.1644899 .
N. Škoberne , O. Maennel , I. Phillips , 等 . IPv4 address sharing mechanism classification and tradeoff analysis . IEEE/ACM Trans. Netw. , 2014 . 22 ( 2 ): 391 - 404 . DOI: 10.1109/TNET.2013.2256147 http://doi.org/10.1109/TNET.2013.2256147 .
P. Srisuresh , K. Egevang . Traditional IP Network Address Translator (Traditional NAT) . RFC 3022 , 2001 . DOI: 10.17487/RFC3022 http://doi.org/10.17487/RFC3022 .
P. Srisuresh , B. Ford , S. Sivakumar , 等 . NAT Behavioral Requirements for ICMP . RFC 5508 , 2009 .
O. Troan , W. Dec , X. Li , 等 . Mapping of Address and Port with Encapsulation (MAP) . Available from , [Accessed on Jan. 8, 2015] 2014 . http://tools.ietf.org/html/rfc7597 http://tools.ietf.org/html/rfc7597 , .
D. Wing . Dynamic TCP Port Reuse for Large Network Address and Port Translators . Available from , [Accessed on Jan. 8, 2015] 2008 . http://tools.ietf.org/html/draft-wing-behave-dynamictcp-port-reuse-00 http://tools.ietf.org/html/draft-wing-behave-dynamictcp-port-reuse-00 , .
关联资源
相关文章
相关作者
相关机构
京公网安备11010802024621