
FOLLOWUS
1College of Command Information Systems, PLA University of Science and Technology, Nanjing 210007, China
2PLA Academy of National Defense Information, Wuhan 430020, China
E-mail:lbo.xidian@163.com
E-mail:mingchennj@163.com
E-mail:xubo820@163.com
收稿:2016-03-07,
录用:2016-6-23,
纸质出版:2016-07
Scan QR Code
一种基于OpenFlow性能驱动的数据中心多路径转发方案[J]. 信息与电子工程前沿(英文), 2016,17(7):647-660.
Bo LIU, Ming CHEN, Bo XU, et al. An OpenFlow-based performance-oriented multipath forwarding scheme in datacenters[J]. Frontiers of Information Technology & Electronic Engineering, 2016, 17(7): 647-660.
一种基于OpenFlow性能驱动的数据中心多路径转发方案[J]. 信息与电子工程前沿(英文), 2016,17(7):647-660. DOI: 10.1631/FITEE.1601059.
Bo LIU, Ming CHEN, Bo XU, et al. An OpenFlow-based performance-oriented multipath forwarding scheme in datacenters[J]. Frontiers of Information Technology & Electronic Engineering, 2016, 17(7): 647-660. DOI: 10.1631/FITEE.1601059.
目的
2
尽管高连通度数据中心网络(例如,FatTree)为任意通信主机对提供了多条可用的传输路径和大量的二分带宽,但目前广泛使用的单路径TCP和ECMP传输协议,由于低效的资源挖掘和分配机制并没有取得较好的网络资源利用效率。本文提出了一种基于性能驱动的多路径转发方案LESSOR,用以提高数据中心网络的资源利用效率。
创新点
2
LESSOR根据控制器的闲忙状态(控制器CPU利用率)动态地调整网络状态的轮询时间(算法1),从而维护更为精细的网络视图;通过使用OpenFlow集中控制手段,LESSOR为短流预安装基于主机粒度负载均衡的路径流表,减小了短流的完成时间并降低了控制器的负载;对于长流,LESSOR根据全局网络视图为每一条流计算近似最优的传输路径和带宽供给(算法2),从而实现更好的负载均衡特性和网络的资源利用率。
方法
2
我们在Mininet仿真平台上使用数据中心网络拓扑(FatTree和VL2)和真实数据中心网络流量对LESSOR进行仿真验证,同时在真实网络环境下部署了LESSOR原型系统进行了进一步的测试。实验表明LESSOR能有效提高网络吞吐量,在不同水平的网络负载下较现有的ECMP方案提高了4.9%-38.3%,较现有典型的Hedera方案也提高了2%-27.7%。同时,实验结果表明LESSOR能有效减小平均流完成时间。
结论
2
本文提出的方案能有效提高网络吞吐量(图4);与Hedera方案相比,本文的方案能有效降低控制器负担,并能充分利用控制器的资源获取更为精细的网络视图(图8)和更高的网络吞吐量(图6)。
Although dense interconnection datacenter networks (DCNs) (e.g.
FatTree) provide multiple paths and high bisection bandwidth for each server pair
the widely used single-path Transmission Control Protocol (TCP) and equal-cost multipath (ECMP) transport protocols cannot achieve high resource utilization due to poor resource excavation and allocation. In this paper
we present LESSOR
a performance-oriented multipath forwarding scheme to improve DCNs' resource utilization. By adopting an OpenFlow-based centralized control mechanism
LESSOR computes near-optimal transmission path and bandwidth provision for each flow according to the global network view while maintaining nearly real-time network view with the performance-oriented flow observing mechanism. Deployments and comprehensive simulations show that LESSOR can efficiently improve the network throughput
which is higher than ECMP by 4.9%-38.3% under different loads. LESSOR also provides 2%-27.7% improvement of throughput compared with Hedera. Besides
LESSOR decreases the average flow completion time significantly.
M Al-Fares , , , A Loukissas , , , A Vahdat . . A scalable, commodity data center network architecture . . ACM SIGCOMM Comput. Commun. Rev. , , 2008 . . 38 ( ( 4 ): ): 63 - - 74 . . DOI: 10.1145/1402946.1402967 http://doi.org/10.1145/1402946.1402967 . .
M Al-Fares , , , S Radhakrishnan , , , B Raghavan , , , 等 . . Hedera: dynamic flow scheduling for data center networks . . 2010 . . Proc. 7th USENIX Conf. on Networked Systems Design and Implementation . . 1 - - 15 . . . .
M Alizadeh , , , A Greenberg , , , DA Maltz , , , 等 . . Data center TCP (DCTCP) . . ACM SIGCOMM Comput. Commun. Rev. , , 2010 . . 41 ( ( 4 ): ): 63 - - 74 . . DOI: 10.1145/1851182.1851192 http://doi.org/10.1145/1851182.1851192 . .
M Alizadeh , , , T Edsall , , , S Dharmapurikar , , , 等 . . CONGA: distributed congestion-aware load balancing for datacenters . . ACM SIGCOMM Comput. Commun. Rev. , , 2014 . . 44 ( ( 4 ): ): 503 - - 514 . . DOI: 10.1145/2619239.2626316 http://doi.org/10.1145/2619239.2626316 . .
T Benson , , , A Akella , , , DA Maltz . . Network traffic characteristics of data centers in the wild . . 2010 . . Proc. 10th ACM SIGCOMM Conf. on Internet Measurement . . 267 - - 280 . . DOI: 10.1145/1879141.1879175 http://doi.org/10.1145/1879141.1879175 . .
T Benson , , , A Anand , , , A Akella , , , 等 . . MicroTE: fine grained traffic engineering for data centers . . 2011 . . Proc. 7th Conf. on Emerging Networking EXperiments and Technologies, Article 8 . . DOI: 10.1145/2079296.2079304 http://doi.org/10.1145/2079296.2079304 . .
M Bredel , , , Z Bozakov , , , A Barczyk , , , 等 . . Flowbased load balancing in multipathed layer-2 networks using OpenFlow and multipath-TCP . . 2014 . . Proc. 3rd Workshop on Hot Topics in Software Defined Networking . . 213 - - 214 . . DOI: 10.1145/2620728.2620770 http://doi.org/10.1145/2620728.2620770 . .
J Cao , , , R Xia , , , P Yang , , , 等 . . Per-packet loadbalanced, low-latency routing for Clos-based data center networks . . 213 . . Proc. 9th ACM Conf. on Emerging Networking EXperiments and Technologies . . 49 - - 60 . . DOI: 10.1145/2535372.2535375 http://doi.org/10.1145/2535372.2535375 . .
Y Chen , , , S Jain , , , VK Adhikari , , , 等 . . A first look at inter-data center traffic characteristics via Yahoo! datasets . . 2011 . . Proc. IEEE INFOCOM . . 1620 - - 1628 . . DOI: 10.1109/INFCOM.2011.5934955 http://doi.org/10.1109/INFCOM.2011.5934955 . .
M Chiesa , , , G Kindler , , , M Schapira . . Traffic engineering with equal-cost-multipath: an algorithmic perspective . . 2014 . . Proc. IEEE Conf. on Computer Communications . . 1590 - - 1598 . . DOI: 10.1109/INFOCOM.2014.6848095 http://doi.org/10.1109/INFOCOM.2014.6848095 . .
AR Curtis , , , JC Mogul , , , J Tourrilhes , , , 等 . . DevoFlow: scaling flow management for high-performance networks . . ACM SIGCOMM Comput. Commun. Rev. , , 2011a . . 41 ( ( 4 ): ): 254 - - 265 . . DOI: 10.1145/2043164.2018466 http://doi.org/10.1145/2043164.2018466 . .
AR Curtis , , , W Kim , , , P Yalagandula . . Mahout: low-overhead datacenter traffic management using endhost-based elephant detection . . 2011b . . Proc. IEEE INFOCOM . . 1629 - - 1637 . . DOI: 10.1109/INFCOM.2011.5934956 http://doi.org/10.1109/INFCOM.2011.5934956 . .
A Dixit , , , P Prakash , , , YC Hu , , , 等 . . On the impact of packet spraying in data center networks . . 2013 . . Proc. IEEE INFOCOM . . 2130 - - 2138 . . DOI: 10.1109/INFCOM.2013.6567015 http://doi.org/10.1109/INFCOM.2013.6567015 . .
A Ford , , , C Raiciu , , , M Handley , , , 等 . . TCP Extensions for Multipath Operation with Multiple Addresses . . RFC 6824 , , 2013 . . DOI: 10.17487/RFC6824 http://doi.org/10.17487/RFC6824 . .
A Greenberg , , , JR Hamilton , , , N Jain , , , 等 . . VL2: a scalable and flexible data center network . . Commun. ACM , , 2011 . . 54 ( ( 3 ): ): 95 - - 104 . . DOI: 10.1145/1897852.1897877 http://doi.org/10.1145/1897852.1897877 . .
N Handigol , , , B Heller , , , V Jeyakumar , , , 等 . . Reproducible network experiments using container-based emulation . . 2012 . . Proc. 8th Int. Conf. on Emerging Networking EXperiments and Technologies . . 253 - - 264 . . DOI: 10.1145/2413176.2413206 http://doi.org/10.1145/2413176.2413206 . .
CY Hong , , , M Caesar , , , PB Godfrey . . Finishing flows quickly with preemptive scheduling . . ACM SIGCOMM Comput. Commun. Rev. , , 2012 . . 42 ( ( 4 ): ): 127 - - 138 . . DOI: 10.1145/2377677.2377710 http://doi.org/10.1145/2377677.2377710 . .
CE Hopps . . Analysis of an Equal-Cost Multi-path Algorithm. RFC 2992 , , 2000 . . Available from: http://www.ietf.org/rfc/rfc2992.txt http://www.ietf.org/rfc/rfc2992.txt . .
S Jain , , , A Kumar , , , S Mandal , , , 等 . . B4: experience with a globally-deployed software defined WAN . . ACM SIGCOMM Comput. Commun. Rev. , , 2013 . . 43 ( ( 4 ): ): 3 - - 14 . . DOI: 10.1145/2534169.2486019 http://doi.org/10.1145/2534169.2486019 . .
A Kabbani , , , B Vamanan , , , J Hasan , , , 等 . . FlowBender: flow-level adaptive routing for improved latency and throughput in datacenter networks . . 2014 . . Proc. 10th ACM Int. Conf. on Emerging Networking EXperiments and Technologies . . 149 - - 160 . . DOI: 10.1145/2674005.2674985 http://doi.org/10.1145/2674005.2674985 . .
QQ Le , , , GW Yang , , , WNN Hung , , , 等 . . Performance-driven assignment and mapping for reliable networks-on-chips . . J. Zhejiang Univ.-Sci. C (Comput. & Electron.) , , 2014 . . 15 ( ( 11 ): ): 1009 - - 1020 . . DOI: 10.1631/jzus.C1400055 http://doi.org/10.1631/jzus.C1400055 . .
XL Li , , , HM Wang , , , CG Guo , , , 等 . . Topology awareness algorithm for virtual network mapping . . J. Zhejiang Univ.-Sci. C (Comput. & Electron.) , , 2012 . . 13 ( ( 3 ): ): 178 - - 186 . . DOI: 10.1631/jzus.C1100282 http://doi.org/10.1631/jzus.C1100282 . .
A Madry . . Faster approximation schemes for fractional multicommodity flow problems via dynamic graph algorithms . . 2010 . . Proc. 42nd ACM Symp. on Theory of Computing . . 121 - - 130 . . DOI: 10.1145/1806689.1806708 http://doi.org/10.1145/1806689.1806708 . .
N McKeown , , , T Anderson , , , H Balakrishnan , , , 等 . . OpenFlow: enabling innovation in campus networks . . ACM SIGCOMM Comput. Commun. Rev. , , 2008 . . 38 ( ( 2 ): ): 69 - - 74 . . DOI: 10.1145/1355734.1355746 http://doi.org/10.1145/1355734.1355746 . .
J Mudigonda , , , P Yalagandula , , , M Al-Fares , , , 等 . . SPAIN: COTS data-center Ethernet for multipathing over arbitrary topologies . . 2010 . . Proc. 7th USENIX Conf. on Networked Systems Design and Implementation . . 18 - - 33 . . . .
Y Peng , , , K Chen , , , G Wang , , , 等 . . HadoopWatch: a first step towards comprehensive traffic forecasting in cloud computing . . 2014 . . Proc. IEEE Conf. on Computer Communications . . 19 - - 27 . . DOI: 10.1109/INFOCOM.2014.6847920 http://doi.org/10.1109/INFOCOM.2014.6847920 . .
H Qi , , , M Shiraz , , , JY Liu , , , 等 . . Data center network architecture in cloud computing: review, taxonomy, and open research issues . . J. Zhejiang Univ.-Sci. C (Comput. & Electron.) , , 2014 . . 15 ( ( 9 ): ): 776 - - 793 . . DOI: 10.1631/jzus.C1400013 http://doi.org/10.1631/jzus.C1400013 . .
C Raiciu , , , M Handley , , , D Wischik , , , 等 . . Coupled Congestion Control for Multipath Transport Protocols . . RFC 6356 , , 2011a . . DOI: 10.17487/RFC6356 http://doi.org/10.17487/RFC6356 . .
C Raiciu , , , S Barre , , , C Pluntke , , , 等 . . Improving datacenter performance and robustness with multipath TCP . . ACM SIGCOMM Comput. Commun. Rev. , , 2011b . . 41 ( ( 4 ): ): 266 - - 277 . . DOI: 10.1145/2043164.2018467 http://doi.org/10.1145/2043164.2018467 . .
C Rotsos , , , N Sarrar , , , S Uhlig , , , 等 . . OFLOPS: an open framework for OpenFlow switch evaluation . . 2012 . . Proc. 13th Int. Conf. on Passive and Active Measurement . . 85 - - 95 . . DOI: 10.1007/978-3-642-28537-0_9 http://doi.org/10.1007/978-3-642-28537-0_9 . .
C Wilson , , , H Ballani , , , T Karagiannis , , , 等 . . Better never than late: meeting deadlines in datacenter networks . . ACM SIGCOMM Comput. Commun. Rev. , , 2011 . . 41 ( ( 4 ): ): 50 - - 61 . . DOI: 10.1145/2018436.2018443 http://doi.org/10.1145/2018436.2018443 . .
C Yu , , , C Lumezanu , , , Y Zhang , , , 等 . . FlowSense: monitoring network utilization with zero measurement cost . . 2013 . . Proc. 14th Int. Conf. on Passive and Active Measurement . . 31 - - 41 . . DOI: 10.1007/978-3-642-36516-4_4 http://doi.org/10.1007/978-3-642-36516-4_4 . .
D Zats , , , T Das , , , P Mohan , , , 等 . . DeTail: reducing the flow completion time tail in datacenter networks . . ACM SIGCOMM Comput. Commun. Rev. , , 2012 . . 42 ( ( 4 ): ): 139 - - 150 . . DOI: 10.1145/2377677.2377711 http://doi.org/10.1145/2377677.2377711 . .
关联资源
相关文章
相关作者
相关机构
京公网安备11010802024621