
FOLLOWUS
1Department of Systems and Computer Engineering, Carleton University, Ottawa, Ontario K1S 5B6, Canada
2School of Computer Science, Carleton University, Ottawa, Ontario K1S 5B6, Canada
3Eion Inc., Ottawa, Ontario K2K 2E3, Canada
E-mail:vigneshrenganathanra@cmail.carleton.ca
E-mail:chlung@sce.carleton.ca
E-mail:abhishekpandey@cmail.carleton.ca
E-mail:guomingwei@gmail.com
E-mail:anand@eion.com
收稿:2016-04-04,
录用:2016-4-24,
纸质出版:2016-07
Scan QR Code
软件定义网络组播中一种基于Subtree来进行失败检测和保护的方法[J]. 信息与电子工程前沿(英文), 2016,17(7):682-700.
Vignesh RENGANATHAN RAJA, Chung-Horng LUNG, Abhishek PANDEY, et al. A subtree-based approach to failure detection and protection for multicast in SDN#[J]. Frontiers of Information Technology & Electronic Engineering, 2016, 17(7): 682-700.
软件定义网络组播中一种基于Subtree来进行失败检测和保护的方法[J]. 信息与电子工程前沿(英文), 2016,17(7):682-700. DOI: 10.1631/FITEE.1601135.
Vignesh RENGANATHAN RAJA, Chung-Horng LUNG, Abhishek PANDEY, et al. A subtree-based approach to failure detection and protection for multicast in SDN#[J]. Frontiers of Information Technology & Electronic Engineering, 2016, 17(7): 682-700. DOI: 10.1631/FITEE.1601135.
目的
2
在软件定义网络(SDN)中,组播应用(比如实时视频流和视频会议)是非常流行的应用。但是这些应用大多对时延要求很高。一个正在进行的组播会话的失败会导致数据包的丢失和延迟,从而严重影响服务质量(QoS)。本文研究软件定义网络组播应用中失败检测和保护的方法。
创新点
2
本文提出了一种基于Subtree来对软件定义网络中OpenFlow交换机的组播树进行失败检测和保护的方法。本方法能够在组播树中检测链路或者节点的失败,并且决定流表中组播树中的哪个部分需要改变来从失败中恢复。
方法
2
利用软件定义网络中的控制平面来进行快速组播失败恢复。在发生失败的情况下,控制器在相应的发生链路或者节点失败的交换机上安装流表。
结论
2
本方法能够有效地在组播树中检测链路或者节点的失败。利用软件定义网络中的中心控制器,能够快速建立备份链路,从而提高系统的服务质量。
Software-defined networking (SDN) has received tremendous attention from both industry and academia. The centralized control plane in SDN has a global view of the network and can be used to provide more effective solutions for complex problems
such as traffic engineering. This study is motivated by recent advancement in SDN and increasing popularity of multicasting applications. We propose a technique to increase the resiliency of multicasting in SDN based on the subtree protection mechanism. Multicasting is a group communication technology
which uses the network infrastructure efficiently by sending the data only once from one or multiple sources to a group of receivers that share a common path. Multicasting applications
e.g.
live video streaming and video conferencing
become popular
but they are delay-sensitive applications. Failures in an ongoing multicast session can cause packet losses and delay
which can significantly affect quality of service (QoS). In this study
we adapt a subtree-based technique to protect a multicast tree constructed for OpenFlow switches in SDN. The proposed algorithm can detect link or node failures from a multicast tree and then determines which part of the multicast tree requires changes in the flow table to recover from the failure. With a centralized controller in SDN
the backup paths can be created much more effectively in comparison to the signaling approach used in traditional multiprotocol label switching (MPLS) networks for backup paths
which makes the subtree-based protection mechanism feasible. We also implement a prototype of the algorithm in the POX controller and measure its performance by emulating failures in different tree topologies in Mininet.
IF Akyildiz , , , A Lee , , , P Wang , , , 等 . . A roadmap for traffic engineering in SDN-OpenFlow networks . . Comput. Netw. , , 2014 . . 71 1 - - 30 . . DOI: 10.1016/j.comnet.2014.06.002 http://doi.org/10.1016/j.comnet.2014.06.002 . .
L Bondan , , , LF Mller , , , M Kist . . Multiflow: multicast clean-slate with anticipated route calculation on Open-Flow programmable networks . . J. Appl. Comput. Res. , , 2012 . . 2 ( ( 2 ): ): 68 - - 74 . . DOI: 10.4013/jacr.2012.22.02 http://doi.org/10.4013/jacr.2012.22.02 . .
B Cain , , , S Deering , , , I Kouvelas . . Internet Group Management Protocol, Version 3. RFC 3376 Internet Engineering Task Force, Fermont , , 2002 . . Available from: http://www.ietf.org/rfc/rfc3376.txt. http://www.ietf.org/rfc/rfc3376.txt . .
Congdon P Link Layer Discovery Protocol. RFC 2922 , , 2002 . . Available from: http://tools.ietf.org/html/rfc2922 http://tools.ietf.org/html/rfc2922 . .
Craig A GroupFlow , , 2014 . . Available from: http://github.com/alexcraig/GroupFlow http://github.com/alexcraig/GroupFlow . .
A Craig , , , B Nandy , , , I Lambadaris , , , 等 . . Load balancing for multicast traffic in SDN using real-time link cost modification . . 2015 . . IEEE Int. Conf. on Communications . . 5789 - - 5795 . . DOI: 10.1109/ICC.2015.7249245 http://doi.org/10.1109/ICC.2015.7249245 . .
S Das . . PAC.C: a Unified Control Architecture for Packet and Circuit Network Convergence , , 2012 . . : USA : Stanford University , , PhD Thesis . .
H Farhady , , , H Lee , , , A Nakao . . Software-defined networking: a survey . . Comput. Netw. , , 2015 . . 81 79 - - 95 . . DOI: 10.1016/j.comnet.2015.02.014 http://doi.org/10.1016/j.comnet.2015.02.014 . .
AG Fei , , , JH Cui , , , M Gerla , , , 等 . . A "dual-tree" scheme for fault-tolerant multicast . . 2001 . . IEEE Int. Conf. on Communications . . 690 - - 694 . . DOI: 10.1109/ICC.2001.937328 http://doi.org/10.1109/ICC.2001.937328 . .
B Fenner , , , M Handley , , , H Holrook , , , 等 . . Protocol Independent Multicast-Sparse Mode (PIM-SM): Protocol Specification (Revised) . . 2006 . . Available from: http://tools.ietf.org/html/rfc4601 http://tools.ietf.org/html/rfc4601 . .
Floodlight Project Floodlight—Open Source Software for Building Software-Defined Networks , , 2015 . . Available from: http://www.projectfloodlight.org/floodlight/ http://www.projectfloodlight.org/floodlight/ . .
WL Huang , , , HY Guo . . A fault-tolerant strategy for multicasting in MPLS networks . . 2009 . . Proc. Int. Conf. on Computer Engineering and Technology . . 432 - - 435 . . DOI: 10.1109/ICCET.2009.138 http://doi.org/10.1109/ICCET.2009.138 . .
D Katz , , , D Ward . . Bidirectional Forwarding Detection (BFD). RFC 5880 . . Internet Engineering Task Force , , 2010 . . Available from: http://tools.ietf.org/html/rfc5880 http://tools.ietf.org/html/rfc5880 . .
J Kempf , , , E Bellagamba , , , A Kern , , , 等 . . Scalable fault management for OpenFlow . . 2012 . . Proc. IEEE Int. Conf. on Communications . . 6606 - - 6610 . . DOI: 10.1109/ICC.2012.6364688 http://doi.org/10.1109/ICC.2012.6364688 . .
N Kitsuwan , , , S McGettrick , , , F Slyne , , , 等 . . Independent transient plane design for protection in OpenFlow-based networks . . J. Opt. Commun. Netw. , , 2015 . . 7 ( ( 4 ): ): 264 - - 275 . . DOI: 10.1364/JOCN.7.000264 http://doi.org/10.1364/JOCN.7.000264 . .
D Kotani , , , K Suzuki , , , H Shimonishi . . A design and implementation of OpenFlow controller handling IP multicast with fast tree switching . . 2012 . . IEEE/IPSJ 12th Int. Symp. on Applications and the Internet . . 60 - - 67 . . DOI: 10.1109/SAINT.2012.17 http://doi.org/10.1109/SAINT.2012.17 . .
D Kreutz , , , FMV Ramos , , , PE Ver -ssimo , , , 等 . . Software-defined networking: a comprehensive survey . . Proc. IEEE , , 2015 . . 103 ( ( 1 ): ): 14 - - 76 . . DOI: 10.1109/JPROC.2014.2371999 http://doi.org/10.1109/JPROC.2014.2371999 . .
B Lantz , , , B Heller , , , N McKeown . . A network in a laptop: rapid prototyping for software-defined networks . . 2010 . . Proc. 9th ACM SIGCOMM Workshop on Hot Topics in Networks . . 19 DOI: 10.1145/1868447.1868466 http://doi.org/10.1145/1868447.1868466 . .
MW Lee , , , YS Li , , , X Huang , , , 等 . . Robust multipath multicast routing algorithms for videos in software-defined networks . . 2014 . . Proc. IEEE 22nd Int Symp. of Quality of Service . . 218 - - 227 . . DOI: 10.1109/IWQoS.2014.6914322 http://doi.org/10.1109/IWQoS.2014.6914322 . .
CAC Marcondes , , , TPC Santos , , , AP Godoy , , , 等 . . CastFlow: clean-slate multicast approach using in-advance path processing in programmable networks . . 2012 . . IEEE Symp. on Computers and Communications . . 94 - - 101 . . DOI: 10.1109/ISCC.2012.6249274 http://doi.org/10.1109/ISCC.2012.6249274 . .
N McKewon , , , T Anderson , , , H Balakrishnan . . OpenFlow: enabling innovation in campus networks . . ACM SIGCOMM Comput. Commun. Rev. , , 2008 . . 38 ( ( 2 ): ): 69 - - 74 . . DOI: 10.1145/1355734.1355746 http://doi.org/10.1145/1355734.1355746 . .
M Medard , , , SG Finn , , , RA Barry , , , 等 . . Redundant trees for preplanned recovery in arbitrary vertex-redundant or edge-redundant graphs . . IEEE/ACM Trans. Netw. , , 1999 . . 7 ( ( 5 ): ): 641 - - 652 . . DOI: 10.1109/90.803380 http://doi.org/10.1109/90.803380 . .
J Moy . . MOSPF: Analysis and Experience RFC 1585. Internet Engineering Task Force, Fremont , , 1994 . . Available from: http://tools.ietf.org/html/rfc1585 http://tools.ietf.org/html/rfc1585 . .
Y Nakagawa , , , K Hyoudou , , , T Shimizu . . A management method of IP multicast in overlay networks using OpenFlow . . 2012 . . Proc. 1st Workshop on Hot Topics in Software Defined Networks . . 91 - - 96 . . DOI: 10.1145/2342441.2342460 http://doi.org/10.1145/2342441.2342460 . .
Open Networking Foundation (ONF) Software-Defined Networking: the New Norm for Networks. ONF White Paper , , 2012 . . Available from: http://www.opennetworking.org/images/stories/downloads/sdn-resources/white-papers/wp-sdn-newnorm.pdf http://www.opennetworking.org/images/stories/downloads/sdn-resources/white-papers/wp-sdn-newnorm.pdf . .
E Osborne , , , A Simha . . Traffic Engineering with MPLS , , 2002 . . : Indianapolis, USA : Cisco Press , , . .
P Pan , , , G Swallow , , , A Atlas . . Fast Reroute Extensions to RSVP-TE for LSP Tunnels. RFC 4090 Internet Engineering Task Force , , 2005 . . Available from: http://tools.ietf.org/html/rfc4090 http://tools.ietf.org/html/rfc4090 . .
T Pfeiffenberger , , , JL Du , , , PB Arruda , , , 等 . . Reliable and flexible communications for power systems: fault-tolerant multicast with SDN/OpenFlow . . 2015 . . 7th IFIP Int. Conf. on New Technologies, Mobility, and Security . . 1 - - 6 . . DOI: 10.1109/NTMS.2015.7266517 http://doi.org/10.1109/NTMS.2015.7266517 . .
Y Pointurier . . Link Failure Recovery for MPLS Networks with Multicasting . . MS Thesis, University of Virginia, Charlottesville, USA , , 2002 . . .
POXST POX Spanning Tree , , 2016 . . Available from: http://github.com/noxrepo/pox/blob/carp/pox/openflow/spanning_tree.py http://github.com/noxrepo/pox/blob/carp/pox/openflow/spanning_tree.py . .
POXTD POX Topology Discovery , , 2014 . . Available from: http://github.com/noxrepo/pox/blob/carp/pox/openflow/discovery.py http://github.com/noxrepo/pox/blob/carp/pox/openflow/discovery.py . .
Python Python Time Complexity , , 2015 . . Available from: http://wiki.python.org/moin/TimeComplexity http://wiki.python.org/moin/TimeComplexity . .
Raja V Renganathan , , , A Pandey , , , CH Lung . . An OpenFlow-based approach to failure detection and protection for a multicasting tree . . LNCS , , 2015 . . 9071 211 - - 224 . . DOI: 10.1007/978-3-319-22572-2_15 http://doi.org/10.1007/978-3-319-22572-2_15 . .
J Rckert , , , J Blendin , , , R Hark , , , 等 . . An Extended Study of DynSdm: Software-Defined Multicast Using Multi-trees. Technical Report, No. RS-TR-2015-01 . . Technische Universit t Darmstadt, Darmstadt, Germany , , 2015 . . .
MY Saidi , , , B Cousin , , , M Molnar . . Improved dual-forest for multicast protection . . 2006 . . 2nd Conf. on Next Generation Internet Design and Engineering . . 371 - - 378 . . DOI: 10.1109/NGI.2006.1678265 http://doi.org/10.1109/NGI.2006.1678265 . .
AR Sharafat , , , S Das , , , G Parulkar , , , 等 . . MPLS-TE and MPLS VPNs with OpenFlow . . 2011 . . Proc. ACM SIGCOMM . . 452 - - 453 . . DOI: 10.1145/2018436.2018516 http://doi.org/10.1145/2018436.2018516 . .
J Tiso . . Designing Cisco Network Service Architectures (ARCH): Developing an Optimum Design for Layer 3 (CCDP) , , 2011 . . : Indianapolis, USA : Cisco Press , , . .
NLM van Adrichem , , , BJ van Asten , , , F Kuipers . . Fast recovery in software-defined networks . . 2014 . . Proc. 3rd European Workshop Software Defined Networking . . 61 - - 66 . . DOI: 10.1109/EWSDN.2014.13 http://doi.org/10.1109/EWSDN.2014.13 . .
GM Wei , , , CH Lung , , , A Srinivasan . . Protecting a MPLS multicast session tree with bounded switchover time . . 2010 . . Int. Symp. on Performance Evaluation of Computer and Telecommunication Systems . . 236 - - 243 . . . .
XR Xu , , , AC Myres , , , H Zhang , , , 等 . . Resilient multicast support for continuous-media applications, IEEE 7th Int . . 1997 . . Workshop on Network and Operating System Support for Digital Audio and Video . . 183 - - 194 . . DOI: 10.1109/NOSDAV.1997.629385 http://doi.org/10.1109/NOSDAV.1997.629385 . .
YL Zhou , , , YS Zhang . . An aggregated multicast fault tolerant approach based on sibling node backup in MPLS . . 2009 . . Int. Conf. on Information Engineering and Computer Science . . 1 - - 4 . . DOI: 10.1109/ICIECS.2009.5364380 http://doi.org/10.1109/ICIECS.2009.5364380 . .
关联资源
相关文章
相关作者
相关机构
京公网安备11010802024621